# URL v2.0.3 - Table of Contents

> Functions to parse URLs including scheme-specific
URLs such as `tel`, `data`, `geo`, `uuid` and `mailto`.
Modelled on the URI module.

## Pages

- [Getting Started](readme.md)
- [Apache License](license.md)
- [Changelog](changelog.md)

## Modules

- [URL](URL.md): Functions for parsing URLs.

- Schemes
  - [URL.Data](URL.Data.md): Parses the scheme-specific part of a `data` URL as defined
in [RFC 2397](https://tools.ietf.org/html/rfc2397).
  - [URL.Geo](URL.Geo.md): Parses the scheme-specific part of a `geo` URL as defined
in [RFC 5870](https://tools.ietf.org/rfc/rfc5870).
  - [URL.Mailto](URL.Mailto.md): Parses the scheme-specific part of a `mailto` URL as defined
in [RFC 6068](https://tools.ietf.org/html/rfc6068).
  - [URL.Tel](URL.Tel.md): Parses the scheme-specific part of a `tel` URL as defined
in [RFC 3966](https://tools.ietf.org/html/rfc3966).
  - [URL.UUID](URL.UUID.md): Parses the scheme-specific part of a `uuid` URL as described in
[draft-kindel-uuid-uri](https://tools.ietf.org/html/draft-kindel-uuid-uri-00),
and the `urn:uuid:` form of the same identifier.

- Exceptions
  - [URL.Parser.ParseError](URL.Parser.ParseError.md): Exception describing a failure to parse the scheme-specific
part of a URL.

